Full list of changes#
Note
These release notes were migrated from the retired Mantid wiki (archive.mantidproject.org). Trac ticket numbers are given for reference alongside the GitHub issue the ticket was migrated to.
Ticket |
Summary |
|---|---|
#2179 (Trac 1332) |
Windows Mantid installer fails without administrator privilages |
#4279 (Trac 3432) |
CalMuonDeadtime algorihtm |
#4289 (Trac 3442) |
ApplyDeadtimeCorr algorihtm |
#4565 (Trac 3718) |
plotting from workspaces sidebar bug linux osx and occasionally windows |
#4762 (Trac 3915) |
Handle different units in proton charge logs |
#4794 (Trac 3947) |
Fix summing in SNSPowderReduction |
#4861 (Trac 4014) |
Add more Run object info when loading Muon Nexus files |
#4926 (Trac 4079) |
Bad alloc when trying to open instrument view |
#5007 (Trac 4160) |
Loading User-algorithms may have gone ga ga |
#5024 (Trac 4177) |
ISIS event mode monitor bug |
#5047 (Trac 4200) |
Investigate Diag differnce from Libisis |
#5048 (Trac 4201) |
Create ConvertToMD |
#5051 (Trac 4204) |
Ensure old- and new-style Python APIs can coexist in the same process |
#5071 (Trac 4224) |
Fix bug with error bars when plotting MatrixWorkspace data |
#5093 (Trac 4246) |
Colour fill plots are always auto scaling the Y axis to bizarre values |
#5096 (Trac 4249) |
Find and fix problems with Mantid not releasing memory |
#5134 (Trac 4287) |
Fix SaveNXSPE to have correct parameters |
#5180 (Trac 4333) |
Export remainder of Python interfaces |
#5190 (Trac 4343) |
MantidPlot Python: segfault for quick typists |
#5267 (Trac 4420) |
Fix Muon Analysis various problems. |
#5270 (Trac 4423) |
Python algorithms are missing if new Python api is the default |
#5278 (Trac 4431) |
MantidPlot crashes if trying to cascade windows |
#5280 (Trac 4433) |
MantidPlot: folder functionality is partially broken |
#5294 (Trac 4447) |
Segfault after deleting a folder |
#5307 (Trac 4460) |
Mantid crashes by invalid input of ConvertToEventWorkspace |
#5314 (Trac 4467) |
SNSPowderReduction does not work on RHEL6 with latest python changes |
#5323 (Trac 4476) |
ORNL SANS interface won’t load in Win32 or RHE5 |
#5327 (Trac 4480) |
real event data converted to MD events and these data rebinned and converted to MD events differ |
#5348 (Trac 4501) |
selectMultiPeak doesn’t work properly |
#5350 (Trac 4503) |
ConvertToMDEvents |
#5367 (Trac 4520) |
Servere slowdown when loading network files through Convert to Energy interface |
#5397 (Trac 4550) |
Incorrect representation after ConvertToMDEvents for reduced Q range. |
#5404 (Trac 4557) |
express MD axis units as related to lattice vectors rather then momentum |
#5413 (Trac 4566) |
Errors in inelastic diag |
#5419 (Trac 4572) |
CovertMatrixtoMD algorithm |
#5451 (Trac 4604) |
3D MDEventWorkspaces no longer load in simple interface |
#5461 (Trac 4614) |
SlicingAlgorithm: adapt to read comma-separated dimension names or IDs |
#5498 (Trac 4651) |
Indirect reduction cannot find files when browsed to |
#5509 (Trac 4662) |
LoadEventNexus: handle multiple preprocessors |
#2834 (Trac 1987) |
Allow Fit Functions to be categorized |
#3464 (Trac 2617) |
Evaluate static analysis tools for Mantid code |
#3497 (Trac 2650) |
Mantid Simple algorithm calls should return he output workspace |
#3643 (Trac 2796) |
Add X error clumn to workspace and error to axes |
#3768 (Trac 2921) |
‘Hidden’ workspaces show up in algorithm dialog comboboxes |
#3769 (Trac 2922) |
Default file type should be ‘all files’ in the Load dialog on a fresh install |
#3773 (Trac 2926) |
Cannot resize the instrument view window on a mac |
#3859 (Trac 3012) |
Sorting the workspace list |
#3923 (Trac 3076) |
Prototype the capability to run Mantid jobs under MPI |
#3989 (Trac 3142) |
Error in Save or Load nexus workspace – source information lost. |
#4039 (Trac 3192) |
Windows: Script generated from history contains backslash paths that don’t work |
#4194 (Trac 3347) |
Workspace context menu plot spectrum needs error bars option |
#4388 (Trac 3541) |
Make loading of files case insentive by default and user modifyable |
#4430 (Trac 3583) |
Peaks overlay for unwrapped view |
#4433 (Trac 3586) |
LoadSQW: optimize for very large files |
#4449 (Trac 3602) |
Add an option on the Muon FitPropertyBrowser to fit against raw data. |
#4465 (Trac 3618) |
SANS: Don’t use monitor 4 to cal neutron background level |
#4488 (Trac 3641) |
Workspace Mementos |
#4541 (Trac 3694) |
plot spectrum dialoge in mantid plot workspace bar |
#4572 (Trac 3725) |
Mac compiler warnings from calls to IFunctionMW::setMatrixWorkspace |
#4585 (Trac 3738) |
Load Dialog can crash: when no loader found |
#4593 (Trac 3746) |
Segfault relating to InstrumentView and possibly masking? |
#4625 (Trac 3778) |
WorkspaceGroups don’t work with binary operations |
#4631 (Trac 3784) |
Certain instrument view python commands don’t work |
#4637 (Trac 3790) |
Fitted workspaces should be put into the correct grouped workspace. |
#4640 (Trac 3793) |
Save ISAW Peaks file failure. |
#4653 (Trac 3806) |
Force style to ‘line’ for MuonAnalysis fit curves |
#4668 (Trac 3821) |
Fix Load Current Run on Muon Analysis interface |
#4684 (Trac 3837) |
When saving/loading MantidPlot project file does not reproduce WS grouping |
#4706 (Trac 3859) |
SliceMD algorithm: make it |
#4711 (Trac 3864) |
Bug in Splatter Plot |
#4722 (Trac 3875) |
LoadEventNexus: Need to be able to filter monitors within a different region |
#4729 (Trac 3882) |
SliceViewer: GUI for quickly viewing 2D slices of ND data |
#4741 (Trac 3894) |
Find and Fix Errors in SQW Loading |
#4750 (Trac 3903) |
Mac crash on loading a project |
#4754 (Trac 3907) |
Refactor IMDWorkspace |
#4755 (Trac 3908) |
Segmentation fault when loading |
#4767 (Trac 3920) |
GroupDetectors2 does not take into account masked detectors when averaging |
#4791 (Trac 3944) |
Create a Nexus reader for ANSTO |
#4792 (Trac 3945) |
AzizAnalysis System Tests |
#4793 (Trac 3946) |
Check new AzizAnalysis expected output System Test |
#4800 (Trac 3953) |
Rebinning corrections to ISIS event files due to non-zero event widths |
#4809 (Trac 3962) |
MDWorkspace: Iterators: limit by implicit function |
#4823 (Trac 3976) |
EventList: EventListTest (parallel) hangs on Mac |
#4829 (Trac 3982) |
Transpose parameter table created by fitting |
#4845 (Trac 3998) |
Cannot save ISIS event files when filtered by time |
#4848 (Trac 4001) |
ExtractSingleSpectrum should be event aware |
#4854 (Trac 4007) |
SANS: Improve output for SaveRKH |
#4856 (Trac 4009) |
Colourbar in 2D plot not working |
#4864 (Trac 4017) |
Nexus2 file fails to load because of date error |
#4867 (Trac 4020) |
broken display of log files |
#4870 (Trac 4023) |
Implement performance tests at ISIS |
#4872 (Trac 4025) |
SmoothNeighbours: generalize the algorithm |
#4885 (Trac 4038) |
Speed up Nearest Neighbours |
#4898 (Trac 4051) |
Amend LoadEventPreNexus so that it’s possible to load a ‘chunk’ |
#4902 (Trac 4055) |
Expand GroupWorkspaces to allow grouping of table workspaces |
#4921 (Trac 4074) |
Fix SmoothNeighbours on WISH |
#4922 (Trac 4075) |
NearestNeighbours With ManagedWorkspaces |
#4927 (Trac 4080) |
Smooth neighbours ignore monitors |
#4938 (Trac 4091) |
Defects in ConvertToQ3DdE |
#4939 (Trac 4092) |
Set focus position for workspace |
#4953 (Trac 4106) |
LET event mode rebin - spikes |
#4954 (Trac 4107) |
Python interface: Add extract methods to MatrixWorkspace to pull out data into numpy |
#4956 (Trac 4109) |
Changes to Indirect Convert To Energy GUI for BASIS |
#4957 (Trac 4110) |
Convert To Energy GUI cannot find correct instrument definition file |
#4963 (Trac 4116) |
Plot MDHistoWorkspaces |
#4964 (Trac 4117) |
SliceViewer: Overlay GUI to define a 1D integration line |
#4968 (Trac 4121) |
Correctly handle VATES simple interface in right-click menu for install kits |
#4980 (Trac 4133) |
Check/fix possible race conditions |
#4981 (Trac 4134) |
Create new tab in muon analysis to plot the results table. |
#4982 (Trac 4135) |
Have the muon results tab construct a table workspace with user specific log values. |
#4983 (Trac 4136) |
Save Mantidplot Projects to a folder (all files inside) |
#4984 (Trac 4137) |
Need ability to save and load peaks |
#4990 (Trac 4143) |
MUON: Run information not displayed in MuonAnalysis |
#4994 (Trac 4147) |
MUON: Have 99 as peak width by default for MuonAnalysis |
#4995 (Trac 4148) |
Table Workspace From HistoWorkspace |
#4996 (Trac 4149) |
Mac system tests are not updating the installed Mantid version |
#4997 (Trac 4150) |
Ignore masked detectors in smooting |
#5011 (Trac 4164) |
Allow Save SPE to Save SPQ files |
#5014 (Trac 4167) |
Plots: increment marker colour to match line colour |
#5015 (Trac 4168) |
Miniplot: Hold line and allow overplot of others |
#5016 (Trac 4169) |
Miniplot: Alternate X axis |
#5017 (Trac 4170) |
Miniplot: Export miniplot data to workspace |
#5019 (Trac 4172) |
SANS: component moved twice for transmission |
#5022 (Trac 4175) |
Add systemtest for UserAlgorithms build script |
#5043 (Trac 4196) |
FileFinder not working on Window with some network path |
#5049 (Trac 4202) |
SQW2 incorrect handling of non-recorded or masked data |
#5050 (Trac 4203) |
Extend SmoothNeighbours to include a Gaussian weighting option |
#5069 (Trac 4222) |
Detector-space PeakFinding |
#5072 (Trac 4225) |
Fix crash in switching out of three slice view |
#5081 (Trac 4234) |
Make the available memory return the correct value on Linux |
#5084 (Trac 4237) |
MUON: In gui first-good-data label swapped around with time-zero label |
#5117 (Trac 4270) |
Fix bug when changing Detectors ID to 0 |
#5120 (Trac 4273) |
Add an option to use the IPython Qt console as a MantidPlot interpreter terminal |
#5124 (Trac 4277) |
SliceViewer: launch slice viewer and set the view from python |
#5125 (Trac 4278) |
Lineviewer: display bin width and allow user to specify it (instead of # of bins) |
#5129 (Trac 4282) |
Investigate ‘Floating windows’ for graphs, matrices etc |
#5145 (Trac 4298) |
Crash on loading script in new window when another one is running |
#5160 (Trac 4313) |
AddLogDerivative: skip repeated time values (0 time interval) |
#5183 (Trac 4336) |
MUON: Add extra property to CalMuonDeadTime |
#5184 (Trac 4337) |
MUON: Improve fitting in CalMuonDeadTime when bad data |
#5203 (Trac 4356) |
Handle dummy spectra in SXD instrument definition |
#5204 (Trac 4357) |
SANS: picking a none disc sample gives nonsense |
#5209 (Trac 4362) |
Fix LoadGrouping bug on Mac. |
#5223 (Trac 4376) |
Mantid curves not redrawn on loading a saved project |
#5232 (Trac 4385) |
Add ExpDecayOsc Fit Function to Mantid |
#5235 (Trac 4388) |
indirect cte: plot energy fails with iris files |
#5250 (Trac 4403) |
SANS: For SANS2D move both rear and front det |
#5254 (Trac 4407) |
SliceViewer: error with 4D workspaces |
#5281 (Trac 4434) |
MUON: Fix problems with load current run. |
#5289 (Trac 4442) |
Algorithms using WorkspaceProperty<EventWorkspace> don’t work in new simple API |
#5291 (Trac 4444) |
incorrect intellisense help for algDialog commands |
#5301 (Trac 4454) |
bleed test error for merlin data |
#5305 (Trac 4458) |
Fix bug when loading file after closing custom interface. |
#5335 (Trac 4488) |
Update Wiki Documentation |
#5338 (Trac 4491) |
Python: Workspace groups can’t be passed into algorithms |
#5339 (Trac 4492) |
Muon: Case Error when fitting against raw data. |
#5346 (Trac 4499) |
DetectorEfficiency needs to average over the number of detectors within each spectrum |
#5349 (Trac 4502) |
Inplace binary ops with new API don’t get called correctly |
#5351 (Trac 4504) |
LineViewer: choose which X coordinate to plot. |
#5353 (Trac 4506) |
HFIR SANS: CropWorkspace breaks Normalization |
#5361 (Trac 4514) |
Muon: Fix Results Table after ADS became case sensitive. |
#5365 (Trac 4518) |
Uncaught exception regarding RTTI is raised when it shouldn’t be |
#5366 (Trac 4519) |
Muon: loose connection |
#5369 (Trac 4522) |
MD Slice viewer should display Dimension name, not dim ID |
#5374 (Trac 4527) |
Spurious crash during ConvertToDiffractionMDWorkspace |
#5377 (Trac 4530) |
Generate Python history script now shows error dialog |
#5378 (Trac 4531) |
Add a third additional spectra to a tosca workspace loaded through the C2E interface |
#5390 (Trac 4543) |
Line Viewer Crash |
#5406 (Trac 4559) |
MUON: Fix crash when Time Axis Start is bigger than Time Axis Finish |
#5416 (Trac 4569) |
Reinsert sans 2d systemtest at Qxy correct errors |
#5417 (Trac 4570) |
ExtractMasking improvements |
#5418 (Trac 4571) |
MUON: Fix network path in run files. |
#5421 (Trac 4574) |
S(Q, w) Gives Incorrect Results |
#5422 (Trac 4575) |
Conv Fit Error |
#5424 (Trac 4577) |
Muon Analysis Interface - throws bad lexical cast on nonsensical “Load run” input |
#5436 (Trac 4589) |
Add errors to output of MuonRemoveExpDecay algorithm |
#5440 (Trac 4593) |
“ACLIMAX” provided as a save format option in Tosca CTE interface. |
#5441 (Trac 4594) |
Convert To Energy GUI cannot set the Ei on a workspace. |
#5464 (Trac 4617) |
Convert To Energy GUI crashes for ARCS and SEQUOIA files |
#5468 (Trac 4621) |
Add option to output in cm-1 to CTE (TOSCA) interface. |
#5476 (Trac 4629) |
MUON: alpha cal |
#5478 (Trac 4631) |
LET definitions need updating |
#5479 (Trac 4632) |
Matho domain error while using MSD Fit tab on IDA interface |
#5480 (Trac 4633) |
CorrectKiKf crashes for BASIS files |
#5481 (Trac 4634) |
Bug saving loading tableworkspaces |
#5483 (Trac 4636) |
SNSPowderReduction got broken by SNAP data |
#5510 (Trac 4663) |
Fix Plot changing to histogram when you group the workspace. |
#5516 (Trac 4669) |
Algorithm*Dialog() commands do not work right in MantidPlot |
#5527 (Trac 4680) |
MoveComponent gives wrong theta values |
#5530 (Trac 4683) |
Rebin2D has edge effects |
#5539 (Trac 4692) |
Remove gap fix for SofQW2 |
#5548 (Trac 4701) |
OneCurvePlot Crashes |
#5559 (Trac 4712) |
ConjoinWorkspaces produces big gap in spectra when they don’t overlap |
#1885 (Trac 1037) |
Crash if accessing python variables assigned to qtiplot windows that have been closed |
#2301 (Trac 1454) |
MantidPlot Indicate to the user with hourglass cursor (for example) when long tasks are running. |
#2491 (Trac 1644) |
Simple Background Quantification |
#2620 (Trac 1773) |
Colour fill plots do not keep their aspect ratio when resizing |
#2791 (Trac 1944) |
Geometry: neutronic (vs. physical) position for components |
#2922 (Trac 2075) |
Improve BASIS instrument geometry |
#3080 (Trac 2233) |
Improve rebinning of SofQW |
#3139 (Trac 2292) |
Create LoadNXSPE |
#3156 (Trac 2309) |
Sort out the dependencies in the tests |
#3225 (Trac 2378) |
Add ‘Plot Style’ to MuonAnalysis Plot Options tab |
#3384 (Trac 2537) |
Fit function toolbar improvements |
#3500 (Trac 2653) |
Harmonise Mantidplot and qtiplot plotting commands |
#3501 (Trac 2654) |
Add stem plots from qtiplot |
#3502 (Trac 2655) |
Allow curves to be manipulated in Python |
#3503 (Trac 2656) |
Add the ability to interact with curves on an existing plot |
#3504 (Trac 2657) |
Better control of error bars from Python |
#3505 (Trac 2658) |
Improve python control of Contour plots |
#3542 (Trac 2695) |
IDF for Polaris upgrade |
#3567 (Trac 2720) |
Display mask in the InstrumentView superimposed on the data in another color |
#3809 (Trac 2962) |
Progress bar for simple GUI |
#3856 (Trac 3009) |
Write analysis system test for SNS direct inelastic reduction |
#3978 (Trac 3131) |
Plus has stopped being commutative |
#4037 (Trac 3190) |
FindSNSNexus doesn’t find _event.nxs files |
#4051 (Trac 3204) |
Test is missing for ParameterMap |
#4136 (Trac 3289) |
Deploy VATES .deb packages |
#4179 (Trac 3332) |
Implement “Send To” functionality for workspaces |
#4189 (Trac 3342) |
Problems with Mantid RPM when MAKE_VATES is set on |
#4206 (Trac 3359) |
Bounding box when integrating |
#4212 (Trac 3365) |
IMDIterator for MDHistoWorkspace |
#4250 (Trac 3403) |
SANS: New type of mask to screen the arm that holds SANS2D’s monitor 4 |
#4298 (Trac 3451) |
SANS: Update Qxy to use the same underlying equations that Q1D uses |
#4364 (Trac 3517) |
Add preNeXus support to SNSPowderReduction |
#4419 (Trac 3572) |
Ability to flip the unrolled instrument view |
#4429 (Trac 3582) |
GPSANS: write geometry for new detector |
#4461 (Trac 3614) |
Implement core layout for update Python API |
#4464 (Trac 3617) |
SANS: Apply M4 shift to transmission and direct beam files also |
#4469 (Trac 3622) |
Create XML based Masking file |
#4486 (Trac 3639) |
Add low-level method to calculate the Niggli reduced cell. |
#4506 (Trac 3659) |
Create algorithm for Detailed Balance correction |
#4512 (Trac 3665) |
Modify the underlying FindUB_UsingMinMaxD method to use FFTs to identify plane normals. |
#4515 (Trac 3668) |
Ensure x-axis scaled correctly when plotting unsorted data |
#4533 (Trac 3686) |
Mask problem detectors for NOMAD data in CalibrateRectangularDetectors |
#4538 (Trac 3691) |
InstrumentView crash when unwrapping |
#4546 (Trac 3699) |
Unary operations are not event aware |
#4551 (Trac 3704) |
SaveIsawPeaks format and append option |
#4552 (Trac 3705) |
SNSSingleCrystalReduction corrections |
#4562 (Trac 3715) |
vtkMDEWHexahedronFactory: 4D case, allow specifying which position to slice at in the 4th dimension |
#4583 (Trac 3736) |
3D Instrument View: crash on attempt to display complex sample |
#4602 (Trac 3755) |
Vates Simple User Interface: Avoid segfault if PV_PLUGIN_PATH is not set |
#4603 (Trac 3756) |
Segfaults/freezes in VatesSimpleGUI with non-3D MDWorkspaces |
#4608 (Trac 3761) |
WorkspaceGroups with invalid members for a given property still appear in the allowedValues list |
#4614 (Trac 3765) |
Odd memory management |
#4615 (Trac 3766) |
GeneratePythonScript to include branched history records |
#4619 (Trac 3770) |
CentroidPeaksMD: Find detector position after centroiding |
#4620 (Trac 3772) |
PredictPeaks: incorrect QSample of predicted peaks? |
#4613 (Trac 3773) |
ConvertToDiffractionMDWorkspace: Check on HKL transformation |
#4626 (Trac 3779) |
Bring up fit parameters from plot window |
#4633 (Trac 3786) |
PlusMD: Incorrect result for file-backed inputs that have had events added but not cached to disk |
#4635 (Trac 3788) |
Default values for the PeakPickerTool within the Muon Analysis interface |
#4636 (Trac 3789) |
PeakPickerTool is associated with a plot when the data analysis tab is clicked |
#4639 (Trac 3792) |
LoadIsawPeaks: hangs on file missing header |
#4644 (Trac 3797) |
IPropertySettings to show EnabledWhenWorkspaceIsType |
#4646 (Trac 3799) |
EQSANS: fix scaling of frame 1 to frame 2 |
#4647 (Trac 3800) |
HFIR SANS: add commands to set beam center for transmission |
#4657 (Trac 3810) |
SIngle crystal peak selection gives an unhandled exception if WS has wrong axes |
#4681 (Trac 3835) |
Fix Plot Guess |
#4682 (Trac 3836) |
InstallerTests don’t distingiush between mantid vates properly |
#4685 (Trac 3838) |
Default no-transform in Visualisation |
#4687 (Trac 3840) |
Expose advanced features of LoadSQW through PV Plugins |
#4688 (Trac 3841) |
Reduction UI: avoid silent crash when user have reduction.py on their python path |
#4689 (Trac 3842) |
Merge changes from Iteration31 to trunk |
#4690 (Trac 3843) |
Make CropWorkspace work for EventWorkspaces |
#4691 (Trac 3844) |
Windows debug test failure |
#4692 (Trac 3845) |
Right-click on a PeaksWorkspace to open it in the Vates Simple GUI |
#4695 (Trac 3848) |
Paraview performance on large files |
#4697 (Trac 3850) |
MDEventWorkspace BoxController: Option to NOT use any MRU |
#4698 (Trac 3851) |
LoadEventPreNeXus error when searching for mapping file |
#4699 (Trac 3852) |
Catalog ‘Investigation Window’ crash when expanding datasets |
#4701 (Trac 3854) |
Check that RunNumber of peak matches RunNumber of workspace in PeakIntegration |
#4705 (Trac 3858) |
Paraview: crash when using the Rebinning filter on a 4D workspace |
#4707 (Trac 3860) |
Paraview: crash if entering bad values in Rebinning filter |
#4708 (Trac 3861) |
Refactor BinToMDHistoWorkspace so that it inherits from a base class |
#4716 (Trac 3869) |
LoadCanSAS1D should set X axis unit as MomentumTransfer |
#4718 (Trac 3871) |
Find a hyperplane in N-dimensions from N-1 vectors on its surface |
#4721 (Trac 3874) |
The default save directory is only added to the search path when it is changed |
#4724 (Trac 3877) |
LoadEventNexus has properties with inconsistent naming styles |
#4726 (Trac 3879) |
GroupWorkspaces autocomplete is incorrect |
#4728 (Trac 3881) |
Add TOPAZ detector |
#4732 (Trac 3885) |
EQSANS: get rid of beamstop transmission code |
#4733 (Trac 3886) |
CheckWorkspacesMatch does not do the correct thing with groups |
#4735 (Trac 3888) |
Optimize CropWorkspace |
#4736 (Trac 3889) |
Remove option “vulcancorrection” in Instrument::calcConversion |
#4738 (Trac 3891) |
Wrong detector positions in MAPS |
#4739 (Trac 3892) |
MAPS IDF update |
#4740 (Trac 3893) |
SaveNXSPE algorithm failing on MARI |
#4743 (Trac 3896) |
SaveIsawDetCal |
#4744 (Trac 3897) |
Add logic (bitwise) operators to SpecialWorkspace |
#4745 (Trac 3898) |
Compile debug version of numpy on Windows |
#4746 (Trac 3899) |
AnvredCorrection for TOF |
#4747 (Trac 3900) |
Allow spaces between group names |
#4748 (Trac 3901) |
Speed up CompressEvents |
#4752 (Trac 3905) |
LoadTofRawNexus: Handle SNAP_3893 |
#4763 (Trac 3916) |
Fix size issue of MDEW nexus in AutoTest |
#4764 (Trac 3917) |
vtkPeakMarkerFactory: add an option to select which dimensions to show |
#4765 (Trac 3918) |
Load Peaks file into standalone GUI |
#4768 (Trac 3921) |
Clean up Tests/SystemTests2 |
#4769 (Trac 3922) |
CropWorkspace: No X axis for ragged bins |
#4770 (Trac 3923) |
getPhi for a DetectorGroup is not right in some circumstances |
#4771 (Trac 3924) |
ScaleFactor needed in SaveHKL |
#4773 (Trac 3926) |
Allow Q3DdE algoritmg to obtain input energy from selected workspace |
#4774 (Trac 3927) |
Refactor MDBoxIterator so that it holds a vector of boxes |
#4777 (Trac 3930) |
Method on IMDWorkspace return signal at a coordinate |
#4778 (Trac 3931) |
Use errors from corrected data in IntegratePeakTimeSlices |
#4779 (Trac 3932) |
Normalize vanadium spectra for SNSSingleCrystalReduction |
#4780 (Trac 3933) |
XIntegrationControl doesn’t get updated if x range is set from python with setBinRange |
#4781 (Trac 3934) |
ConvertUnits should leave sort order |
#4782 (Trac 3935) |
Call StripPeaks in StripVanadiumPeak |
#4784 (Trac 3937) |
Add option to skip solid angle weigthing in Q1D |
#4786 (Trac 3939) |
Switch view for views needing accept doesn’t work. |
#4787 (Trac 3940) |
Correct post rendering issues for ThreeSlice view |
#4790 (Trac 3943) |
CTE Interface does not work for HYSPEC |
#4795 (Trac 3948) |
PredictPeaks does not put run number in peaks workspace |
#4796 (Trac 3949) |
ORNL SANS: fix I(Q) normalization |
#4797 (Trac 3950) |
ORNL SANS: save Qxy results in Nexus format |
#4798 (Trac 3951) |
EQSANS: Refactor normalisation step as workflow algo |
#4801 (Trac 3954) |
Have ParaVIew sources/readers publish workspace type |
#4802 (Trac 3955) |
Replace Gauss1D by Fit in StripPeaks |
#4803 (Trac 3956) |
FindPeak does not work well with weak peaks |
#4804 (Trac 3957) |
The Windows installer needs to clean up before running |
#4805 (Trac 3958) |
Make VATES views handle sources better |
#4806 (Trac 3959) |
Make VATES views handle time updates |
#4810 (Trac 3963) |
HFIR SANS: write workflow alg for data loading |
#4812 (Trac 3965) |
Fix .s01 load file in SANS |
#4814 (Trac 3967) |
RemoveLowResTOF/DiffractionFocussing PG3_4868 |
#4815 (Trac 3968) |
Enable SNS ICat3 Search |
#4816 (Trac 3969) |
PredictPeaks: row and col of peaks are not accurate |
#4821 (Trac 3974) |
HFIR SANS: write workflow alg for dark current |
#4822 (Trac 3975) |
Revise the ICat Investigation and Dataset Display |
#4825 (Trac 3978) |
PerformanceTests: fix for git |
#4826 (Trac 3979) |
PeakPickerTool is associated with most recent used plot |
#4828 (Trac 3981) |
Remove toolbars from the top when loading MuonAnalysis |
#4831 (Trac 3984) |
WikiMaker improvements |
#4833 (Trac 3986) |
Fix Multiple run ending in .nxs.nxs |
#4834 (Trac 3987) |
Upcast shared_ptr<DataItem> to correct type in Python |
#4835 (Trac 3988) |
ORNL SANS: add WorkflowAlg for sensitivity correction |
#4837 (Trac 3990) |
EQSANS UI: fit transmission separately for each frame |
#4838 (Trac 3991) |
OrientedLattice: set U matrix using u,v vectors |
#4839 (Trac 3992) |
CMake: Nexus location isn’t picked up properly |
#4842 (Trac 3995) |
Add 2 detector banks to TOPAZ IDF |
#4843 (Trac 3996) |
Remove Dead Code |
#4844 (Trac 3997) |
Upgrades to system tests |
#4847 (Trac 4000) |
MantidDock cannot be resized smaller than width of the four buttons |
#4850 (Trac 4003) |
Adjust Color Scaling |
#4851 (Trac 4004) |
Expose Options in ConvertToDiffractionMDWorkspace |
#4852 (Trac 4005) |
Expose Split into and Split Threshold |
#4853 (Trac 4006) |
ManitdPlot: Move the detector table to use getSpectrum over the spectraAxis |
#4858 (Trac 4011) |
Fix the obvous memory leaks shown by cppcheck |
#4863 (Trac 4016) |
Update the windows installer file names to include the version number |
#4865 (Trac 4018) |
Exposing DateAndTime operators to python |
#4868 (Trac 4021) |
Display log plots relative to run_start by default |
#4875 (Trac 4028) |
PlusMDTest file+file test fails on windows |
#4881 (Trac 4034) |
Plot Spectra Dialog - Add “Plot All” button. |
#4883 (Trac 4036) |
Implement all binary and unary operations for the MDHistoWorkspace |
#4886 (Trac 4039) |
ColorBarWidget: widget showing a color bar and allowing the user to quickly change it |
#4890 (Trac 4043) |
Move BoxController to API |
#4895 (Trac 4048) |
EQSANS: provide a data catalog table for a given experiment |
#4899 (Trac 4052) |
Copy constructor/cloner for MDHistoWorkspace |
#4900 (Trac 4053) |
Fix builds on Fedora 14 and 15 |
#4908 (Trac 4061) |
Base class for Binary/Unary operations on MDWorkspaces |
#4915 (Trac 4068) |
CentroidPeaks algorithm |
#4918 (Trac 4071) |
Allow numpy arrays to be passed into properties through python interface |
#4919 (Trac 4072) |
Extend SmoothNeighbours |
#4920 (Trac 4073) |
TableWorkspace from find peak alg does not save/load correctly |
#4928 (Trac 4081) |
SetMDUsingMask |
#4930 (Trac 4083) |
Expose BinaryOperationMD to python |
#4932 (Trac 4085) |
Expose MDHistoWorkspace to python |
#4933 (Trac 4086) |
Need getScattering function for peak object |
#4935 (Trac 4088) |
ColorBarWidget: do not limit user’s entry for min/max range |
#4936 (Trac 4089) |
Improve test coverage for Python operators |
#4937 (Trac 4090) |
Devote more space to view in Multislice mode |
#4942 (Trac 4095) |
Move color options widget to dialog |
#4945 (Trac 4098) |
Modify Normalize by Monitor algorithm to work porperly. |
#4946 (Trac 4099) |
ConvertToEventWorkspace: skip any NAN or INF bins |
#4948 (Trac 4101) |
MultiplyMD, DivideMD: support MDEventWorkspace*scalar |
#4950 (Trac 4103) |
Axis Scaling after Rebinning |
#4958 (Trac 4111) |
The parameter map needs to be able to be searched case insensitively |
#4959 (Trac 4112) |
Collapse space from top widgets in main view |
#4961 (Trac 4114) |
SANS: add data stitcher |
#4965 (Trac 4118) |
Add features for resetting the view |
#4969 (Trac 4122) |
LineViewer: 1D integration of MDWorkspace GUI: Specify start/end points, width |
#4974 (Trac 4127) |
Mantid workspace index dialog fails if the workspace has no instrument associated with it. |
#4975 (Trac 4128) |
Plot Spectrum doesn’t work for groups containing Table Workspaces |
#4976 (Trac 4129) |
LoadIsawDetCal modifications |
#4977 (Trac 4130) |
IntegratePeaksMD: expand sphere radius and plot a graph |
#4978 (Trac 4131) |
SANS UI: close window when no instrument is selected |
#4985 (Trac 4138) |
Redesign DiskMRU to simplify it |
#4987 (Trac 4140) |
SliceViewer: some bugs |
#4988 (Trac 4141) |
Add parallel projection capability to simple interface |
#4989 (Trac 4142) |
Option for not using IkedaCarpenter TOF fit for integrating corrected data |
#4992 (Trac 4145) |
IntegratePeaksMD: allow a “shell” background size |
#4998 (Trac 4151) |
Add methods to send different level log messages from python |
#4999 (Trac 4152) |
Pull common code into MantidCurve |
#5000 (Trac 4153) |
Allow Load to work with unknown properties. |
#5002 (Trac 4155) |
Finding UB with known lattice should print the difference between refined parameters and the given ones |
#5006 (Trac 4159) |
Have the ability to turn off being clever with Error bars. |
#5008 (Trac 4161) |
Have a default option to overwrite a plot in muon analysis. |
#5009 (Trac 4162) |
Glob fails on directories that don’t exist. Write the Glob test. |
#5012 (Trac 4165) |
RectangularDetector: Allow dynamically changing the size of the detector using a parameter |
#5018 (Trac 4171) |
FindPeaksMD: Support MDHistoWorkspace |
#5020 (Trac 4173) |
Fix sort for Peaks Table |
#5025 (Trac 4178) |
Add getxmin and getxmax to MatrixWorkspace |
#5029 (Trac 4182) |
Run Mantid through memcheck and fix any issues |
#5030 (Trac 4183) |
MDHistoWorkspace: getError() is returning the square of the error |
#5032 (Trac 4185) |
Handling negative errors in Fit and MuonAsymmetryCalc |
#5035 (Trac 4188) |
Different error calculation for MuonAsymmetryCalc |
#5036 (Trac 4189) |
Expose QueryMDWorkspace via MantidPlot |
#5038 (Trac 4191) |
BinMD: Allow binning a MDHistoWorkspace |
#5040 (Trac 4193) |
Auto-overwrite option also to work when changing grouping tab values |
#5041 (Trac 4194) |
Over Plotting of MDWorkspaces |
#5042 (Trac 4195) |
LoadDetectorInfo takes a long time to run and consumes lots of memory |
#5044 (Trac 4197) |
SANS: intepolation bug |
#5053 (Trac 4206) |
LineViewer: empty output in some circumstances |
#5057 (Trac 4210) |
Interface scripter: improve error handling |
#5059 (Trac 4212) |
PeakIntegration check if bank is RectangularDetector |
#5060 (Trac 4213) |
Orbiter should check to see if files exist |
#5062 (Trac 4215) |
Convert Fullprof instrument file to GSAS instrument file |
#5064 (Trac 4217) |
SaveHKL changes |
#5067 (Trac 4220) |
Improve the speed/accuracy of python auto complete. |
#5073 (Trac 4226) |
Import PythonAlgorithms into new framework |
#5077 (Trac 4230) |
Add Squish testing to unit test infrastructure |
#5083 (Trac 4236) |
A problem in ParameterMap |
#5090 (Trac 4243) |
SliceViewer: set axes min/max manually |
#5094 (Trac 4247) |
Implement log rotation |
#5095 (Trac 4248) |
InstrumentView: Remove peak labels when PeaksWorkspace is deleted. |
#5097 (Trac 4250) |
ConjoinWorkspaces for event workspaces messes up the spectrum numbering |
#5100 (Trac 4253) |
Crash when showing Instrument Window after LoadEmptyInstrument/makeEventWorkspace |
#5101 (Trac 4254) |
Expose PeaksWorkspace to python |
#5102 (Trac 4255) |
Sort events by absolute time |
#5105 (Trac 4258) |
LoadEventNexus slow for ISIS event files |
#5108 (Trac 4261) |
GetEi refuses to do anything with an EventWorkspace input |
#5110 (Trac 4263) |
PredictPeaks: option not to round HKLs |
#5111 (Trac 4264) |
Movable mantid |
#5112 (Trac 4265) |
Algorithm to calculate Y / E |
#5115 (Trac 4268) |
CMake cannot find qscintilla on a Mac |
#5116 (Trac 4269) |
The angle() method in V2D and V3D can return NaN even if both vectors are non-zero. |
#5119 (Trac 4272) |
Qt: Make a reusable object that syncs a checkable menu and a checkable button |
#5122 (Trac 4275) |
SliceViewer: export to an image file (or image clipboard) |
#5123 (Trac 4276) |
SliceViewer: read XML from multislice to open the slice viewer at a particular point |
#5128 (Trac 4281) |
Peak overlay improvements |
#5132 (Trac 4285) |
PeakIntegration and IntegratePeakTimeSlices for instruments with no rectangular detectors |
#5135 (Trac 4288) |
Improve Nearest Neighbours |
#5136 (Trac 4289) |
Change Algorithm categories |
#5137 (Trac 4290) |
ORNL SANS: allow multiple background files to be combined |
#5139 (Trac 4292) |
TimeSeriesProperty inefficiencies |
#5144 (Trac 4297) |
Code improvements according to code review |
#5146 (Trac 4299) |
Investigate way old MUON nexus format does not load |
#5147 (Trac 4300) |
MUON: Remove the ‘to’ and ‘from’ columns off the results tab |
#5148 (Trac 4301) |
Make scale bars in Multislice view expand |
#5154 (Trac 4307) |
Don’t allow the ResultsTable tab to populate its tables with workspaces that have the same parameters |
#5155 (Trac 4308) |
MAPS IDF update |
#5156 (Trac 4309) |
Allow use of space/tab in SaveAscii |
#5157 (Trac 4310) |
Open SliceView from a Multislice cut |
#5161 (Trac 4314) |
Calibration using multiple peaks |
#5162 (Trac 4315) |
Export geometry namespace |
#5163 (Trac 4316) |
SliceViewer: add GUI testing |
#5165 (Trac 4318) |
Fix existing Installers for Windows7 64bit |
#5167 (Trac 4320) |
Fix tolerance on HFIREff system test |
#5168 (Trac 4321) |
SANS: extra check of PixelAdj in Q1D & Qxy |
#5169 (Trac 4322) |
Fix MemoryLeak in ConvertToMatrixWorkspace |
#5172 (Trac 4325) |
Make it more clear when row in ‘detector table view’ is not a detector |
#5173 (Trac 4326) |
When IDF det coord. are overwritten from raw/nexus inform users |
#5175 (Trac 4328) |
Simple CreateMDWorkspace GUI |
#5179 (Trac 4332) |
Make LoadIsawUB use MINITOPAZ geometry |
#5186 (Trac 4339) |
Merge workspace’s logs |
#5187 (Trac 4340) |
Implement a factory for SliceViewer widget creation |
#5188 (Trac 4341) |
Remove scripting environment aspects from Note class |
#5189 (Trac 4342) |
SliceViewer Python Interface: add simple method for use within mantidplot |
#5194 (Trac 4347) |
Screenshot-taking unit test |
#5195 (Trac 4348) |
Rename log |
#5196 (Trac 4349) |
Expose waterfall plot creation to Python |
#5198 (Trac 4351) |
GroupDetectors should average by the number of spectra not detectors in the new group |
#5199 (Trac 4352) |
Write SystemTest for TOPAZ peak finding, indexing and UB finding. |
#5202 (Trac 4355) |
SliceViewer: possible crash on empty workspace? |
#5207 (Trac 4360) |
Add a documentation target to CMake |
#5208 (Trac 4361) |
ConjoinWorkspaces does not carry over masking from the second workspace |
#5211 (Trac 4364) |
Change the overwrite and auto-update buttons to a drop down box. |
#5218 (Trac 4371) |
Converte Workspace2D to SpecialWorkspace2D |
#5220 (Trac 4373) |
ORNL SANS: make sure dQ is dealt with when stitching |
#5222 (Trac 4375) |
Make MantidPlot unit test for simple 1D plotting methods |
#5224 (Trac 4377) |
ConvertToDiffractionMDWorkspace: occasional errors in unit tests on RHEL6 / Ubuntu 10.04 |
#5226 (Trac 4379) |
Add SystemTest for file-backed MDWorkspace manipulation |
#5228 (Trac 4381) |
datevalidator test fails in year 2012 |
#5229 (Trac 4382) |
HFIR SANS: compute source-to-sample dist |
#5233 (Trac 4386) |
Add analytical derivates to ExpDecayOsc |
#5234 (Trac 4387) |
Expose goniometer via Python API |
#5236 (Trac 4389) |
Python handle still valid after DeleteWorkspace in MantidPlot |
#5237 (Trac 4390) |
ORNL SANS: clean up GetMaskedDetectors calls |
#5238 (Trac 4391) |
ORNL SANS: add scroll bar to stitcher tab |
#5240 (Trac 4393) |
Option for faster FindPeaks |
#5242 (Trac 4395) |
Move Algorithm categroies |
#5245 (Trac 4398) |
LineViewer: expose to python |
#5249 (Trac 4402) |
Solve Python script change bug in indirect C2E |
#5259 (Trac 4412) |
Windows starting out hidden on loading a saved project |
#5269 (Trac 4422) |
Crash when exiting after calling a wiki help page |
#5272 (Trac 4425) |
Show Data shows hourglass symbol on dialog box |
#5282 (Trac 4435) |
set floating windows defaults for new users |
#5284 (Trac 4437) |
send to error not caught at a sensible level |
#5304 (Trac 4457) |
Problems with updating with a case insensitive ADS |
#5309 (Trac 4462) |
Python error after closing a tab in the script window |
#5322 (Trac 4475) |
Render 3D MDHistoWorkspaces |
#5328 (Trac 4481) |
Converted To Inelastic MD events data are rotared by 90% wrt similar MSlice image |
#5329 (Trac 4482) |
StripVanadiumPeak fails on NOMAD data |
#5357 (Trac 4510) |
Reuse code in MantidQwtIMDWorkspaceData in LineViewer |
#5358 (Trac 4511) |
LineViewer: bug plotting X coordinates of line in a MDHistoWS |
#5364 (Trac 4517) |
Remove otool usage from Python startup |
#5371 (Trac 4524) |
Slice Viewer Crash |
#5372 (Trac 4525) |
Irritating property warning |
#5373 (Trac 4526) |
Color Updates Fail |
#5375 (Trac 4528) |
MUON: Fix some of the options in the Muon interface not saving when you close it down. |
#5376 (Trac 4529) |
dataX,Y,E methods are missing on the new Python API |
#5379 (Trac 4532) |
MUON: Fix Auto-Update with no data. |
#5380 (Trac 4533) |
Color options crashes on threeslice view |
#5381 (Trac 4534) |
LoadRaw dialog: box to enter workspace name is missing on the Mac |
#5382 (Trac 4535) |
CropWorkspace does not preserve event sort order |
#5386 (Trac 4539) |
DiffractionFocusing fails on a GEM file |
#5387 (Trac 4540) |
MUON: Add option to hide toolbars in Muon Analysis. |
#5394 (Trac 4547) |
MUON: Various bugs with line+symbol and scatter graphs. |
#5400 (Trac 4553) |
MaskDetectors takes SpecialWorkspace2D as a special case |
#5402 (Trac 4556) |
MUON: Change auto-update to pick up text edit boxes when the user has finished typing. |
#5408 (Trac 4561) |
Plus isn’t summing total proton charge correctly if RHSWorkspace=Output |
#5409 (Trac 4562) |
Add method to set a minimum recursion depth on a new MDEventWorkspace |
#5411 (Trac 4564) |
Animation for non 4D workspaces |
#5412 (Trac 4565) |
Add help launch for simple interface |
#5420 (Trac 4573) |
Error bar colour does not match curve colour |
#5426 (Trac 4579) |
repeated entries in the user directories |
#5428 (Trac 4581) |
MUON: Changes to Settings tab. |
#5429 (Trac 4582) |
Muon: fit with exponential decay functions does not return errors |
#5430 (Trac 4583) |
Windows installer can pick USB drive has default install location |
#5433 (Trac 4586) |
Colorfill plot gives large gap for MARI when converted to DeltaE |
#5434 (Trac 4587) |
CreateWorkspace cannot be given a numpy array with dimension > 1 |
#5438 (Trac 4591) |
Disable Rebinning Button |
#5442 (Trac 4595) |
Add index operator access to WorkspaceGroup |
#5444 (Trac 4597) |
Add option for user to input instrument name |
#5446 (Trac 4599) |
Disable splatter plot for MDHistoWorkspaces |
#5449 (Trac 4602) |
Disable buttons in StandardView for PeaksWorkspace |
#5450 (Trac 4603) |
Error in operator+= for TimeSeriesProperty |
#5452 (Trac 4605) |
Add lib directory to Python path in MantidPlot |
#5457 (Trac 4610) |
Fit curves are not deleted after selecting “Clear fit curves” in the fit browser. |
#5459 (Trac 4612) |
Add an importAll method to the ADS in python |
#5460 (Trac 4613) |
MUON: Result table changes (due to feedback) |
#5462 (Trac 4615) |
MaskWorkspaceToCalFile |
#5466 (Trac 4619) |
No active source in Splatter to Standard view with peaks overlay |
#5469 (Trac 4622) |
Change MWRunFiles to Disallow Mutilple Files by Default |
#5470 (Trac 4623) |
MUON: Add sum of counts in the run information box. |
#5471 (Trac 4624) |
MUON: Log values should be the average value while within the run time. |
#5473 (Trac 4626) |
MUON: Disable sequential fit for Muon Analysis’ Fit Property Browser. |
#5475 (Trac 4628) |
Value Error when running IRIS _red.nxs file in Abs(F2PY) tab of Indirect Data Analysis tab |
#5485 (Trac 4638) |
Floating InstrumentView does not receive keyboard focus when first open. |
#5486 (Trac 4639) |
Write an algorithms for creating a 1 spectrum MatrixWorkspace from a table. |
#5489 (Trac 4642) |
Bug fixes for merging cal falies |
#5491 (Trac 4644) |
Lower recursion depth on initial view |
#5493 (Trac 4646) |
isDistribution member is missing from MatrixWorkspace interface in Python |
#5495 (Trac 4648) |
MUON: Fix plotting rebunched group with last point being gaga. |
#5497 (Trac 4650) |
TimeSeriesProperty is also missing from Python |
#5501 (Trac 4654) |
ConvertInstrumentFile takes 2theta |
#5502 (Trac 4655) |
Fix workspace type info for SVI |
#5503 (Trac 4656) |
CalibrateRectangularDetector needs 3rd peak for CrossCorrelation |
#5505 (Trac 4658) |
Size function for GroupWorkspace in new Python API |
#5508 (Trac 4661) |
New option for CreateGroupingWorkspace |
#5511 (Trac 4664) |
MUON: Fix crash when you close Muon Analysis with peak picker tool assigned. |
#5522 (Trac 4675) |
MUON: Sync the grouping tab with the home tab. |
#5525 (Trac 4678) |
LoadPreNexus |
#5528 (Trac 4681) |
Log filtering does not work for periods or running status |
#5529 (Trac 4682) |
Enable QtiPlot fitting. |
#5531 (Trac 4684) |
Port class_maker.py to optparse |
#5532 (Trac 4685) |
MUON: Temporarily disable the next and previous buttons when loading. |
#5533 (Trac 4686) |
Instrument view miniplot stores curve for a wrong detector on the Mac |
#5534 (Trac 4687) |
MUON: Add column types to the results table. |
#5536 (Trac 4689) |
Transpose isn’t right when used after SofQW2 |
#5538 (Trac 4691) |
MUON: Change results tab so that you can see all workspaces with fitted parameters. |
#5541 (Trac 4694) |
Add Moderator T0 correct into Indirect Reduction for BASIS |
#5542 (Trac 4695) |
Enable the phi axis on the instrument view miniplot |
#5545 (Trac 4698) |
MUON: Signals not connecting when opening Muon Analysis. |
#5546 (Trac 4699) |
MUON: When loading a grouping file with auto-update on it loads several plots. |
#5547 (Trac 4700) |
Add a method to extract axis values to a sequence |
#5552 (Trac 4705) |
[IDA] - CubicFit and MSDFit changes |
#5553 (Trac 4706) |
The simple Python function for Fit does not work in the new API |
#5554 (Trac 4707) |
Filename Change |
#5555 (Trac 4708) |
Unit Cell check input angles |
#5562 (Trac 4715) |
OrientedLattice exposed to python issue |
#5563 (Trac 4716) |
GUI for choosing the PlotMD options. |
#5568 (Trac 4721) |
Make the fitted curve always have a line style. |
#5569 (Trac 4722) |
MUON: Add the file extension when saving grouping files on a Mac. |
#5570 (Trac 4723) |
Add a very simple function to return the Python API number |
#1887 (Trac 1039) |
Binary op between a single number and a workspace are (1/a) are disallowed |
#2950 (Trac 2103) |
Convert FindPeaks to use new type fitting functions |
#3351 (Trac 2504) |
Update the ICat tests so they don’t rely on the real server |
#4002 (Trac 3155) |
Usability upgrades to System Tests |
#4072 (Trac 3225) |
MUON: PlotAsymmetryByLogValue - also plot none double values |
#4098 (Trac 3251) |
Muon Analysis UI on Mac nigglies |
#4099 (Trac 3252) |
Expose debug log level in python |
#4160 (Trac 3313) |
New warnings added to LoadNexusProcessed and NexusFileIO |
#4203 (Trac 3356) |
Remove/Replace SQW files that don’t work |
#4344 (Trac 3497) |
Save peaks workspace as hkl file |
#4478 (Trac 3631) |
Warning message on loading event files with potentially corrupt pulse times |
#4495 (Trac 3646) |
Replace AlgorithmHelper with calls to FrameworkManager::exec |
#4501 (Trac 3654) |
Add “PreserveEvents” box to SaveNexusProcessed |
#4556 (Trac 3709) |
MoveInstrumentComponent & RotateInstrumentComponent code duplication |
#4571 (Trac 3724) |
Script to generate wiki pages and post them |
#4574 (Trac 3727) |
Missing Algorithm Docs |
#4588 (Trac 3741) |
CloneWorkspace: pass through to CloneMDWorkspace and clone PeaksWorkspace too |
#4623 (Trac 3776) |
MUON: Add EMU default grouping file |
#4642 (Trac 3795) |
Clean up old code, especially disabled test code |
#4683 (Trac 3834) |
Crash when setting MultiThreaded.MaxCores to > number of machine cores |
#4694 (Trac 3847) |
When creating grouping from Nexus file name pair ‘long’ not ‘pair’ |
#4696 (Trac 3849) |
Show AlgorithmHistory in menu for MDHistoWorkspace |
#4709 (Trac 3862) |
Add commented out properties to default config file |
#4712 (Trac 3865) |
Give better error message when FindSNSNeXus cannot initialize |
#4730 (Trac 3883) |
Algorithms are each initialized 20 times during MantidPlot startup. |
#4749 (Trac 3902) |
Rename DiffractionEventReadDetCal to LoadIsawDetCal |
#4775 (Trac 3928) |
Expose ObjCompAssemply to python |
#4789 (Trac 3942) |
Rebin leaves range intact |
#4808 (Trac 3961) |
Write out python script at end of SNSPowderReduction |
#4819 (Trac 3972) |
Select output units in SNSPowderReduction |
#4820 (Trac 3973) |
Show the full component path in the instrument view |
#4830 (Trac 3983) |
class_maker.py |
#4841 (Trac 3994) |
class_maker and related scripts: fix for git |
#4862 (Trac 4015) |
Update test viewer for git |
#4876 (Trac 4029) |
LoadIsawDetCalTest is pretty slow |
#4880 (Trac 4033) |
Plot Spectra Dialog - Swap Spectra/Workspace Fields |
#4893 (Trac 4046) |
wiki_maker: Handle versions of algorithms |
#4897 (Trac 4050) |
LoadEventNexus: swallow event_index warning for banks with no events |
#4914 (Trac 4067) |
Add performance tests for our most important loading algorithms |
#4917 (Trac 4070) |
Create an array lenght validator |
#4924 (Trac 4077) |
LoadEventNexus needs to set X boundaries even if no events are loaded |
#4971 (Trac 4124) |
add log normal distribution to the menu of Fit functions |
#4991 (Trac 4144) |
ConvertToDiffractionMDWorkspace: Don’t append by default |
#5003 (Trac 4156) |
SliceViewer: break out the GUI from MDI (make free-floating) |
#5027 (Trac 4180) |
LineOverlay: hold shift key to limit angle to 45 degree increments |
#5039 (Trac 4192) |
Clean up test files created |
#5054 (Trac 4207) |
SliceViewer: add icon |
#5055 (Trac 4208) |
Parallelize DiffractionFocussing - histogram branch |
#5056 (Trac 4209) |
Additional lines in GSAS file |
#5063 (Trac 4216) |
SliceViewer: Add Help menu and F1 key |
#5085 (Trac 4238) |
SliceViewer: show position in original workspace with mouse movement |
#5092 (Trac 4245) |
CalculateUMatrix should require at least two peaks |
#5109 (Trac 4262) |
SmoothNeighbours: incorrect errors? |
#5118 (Trac 4271) |
SliceViewer: put the menu in the QMainWindow |
#5127 (Trac 4280) |
Ubuntu: icons do not show up next to menu items |
#5149 (Trac 4302) |
Fix issue with indicators not showing up where clicked in Multislice view |
#5153 (Trac 4306) |
Line Viewer Crash 4 Dimensions |
#5174 (Trac 4327) |
OrientedLattice seems to permeate itself throughout the code |
#5193 (Trac 4346) |
SliceViewer: adjustments for Mac |
#5200 (Trac 4353) |
IndexPeaks: add an Output property with # of indexed peaks |
#5206 (Trac 4359) |
Deprecating algorithms |
#5212 (Trac 4365) |
Create an algorithm that returns Min, similar to Max |
#5214 (Trac 4367) |
Add option to compress processedNexus files for EventWorkspaces |
#5215 (Trac 4368) |
Add a cppcheck target |
#5219 (Trac 4372) |
ICat: rename class files to match class names |
#5244 (Trac 4397) |
SliceViewer: line overlay is not hidden when panning |
#5293 (Trac 4446) |
Warning message in SliceViewer |
#5347 (Trac 4500) |
Make workspaces rebinned from Paraview have a non-private name |
#5383 (Trac 4536) |
Rename MergeMD to MergeMDFiles |
#5399 (Trac 4552) |
Change MDEventWorkspace icon to just MDWorkspace icon |
#5403 (Trac 4555) |
Need Help button and Clear Wiki documentation |
#5405 (Trac 4558) |
Change Simple View Icon Color |
#5435 (Trac 4588) |
LineViewer: minor GUI tweaks |
#5455 (Trac 4608) |
Change IRIS_graphite_004_Parameters “efixed-val” property |
#5477 (Trac 4630) |
Binary operation on workspace group can fail to group the output |
#5487 (Trac 4640) |
Unclear whether Background Removal is on or off by default in CTE interface. |
#5556 (Trac 4709) |
Change the fit property browser option name. |
#4103 (Trac 3256) |
LoadCalFile output workspaces improvement |
#4612 (Trac 3771) |
FindPeaksMD: scale BinCount value by say 10^-5 |
#4874 (Trac 4027) |
More helpful message from DateTime constructor from string when it fails |
#4962 (Trac 4115) |
Group name is a little squished together in algorithm dialog under windows |
#5031 (Trac 4184) |
Rename BinToMDHistoWorkspace to BinMD |
#5126 (Trac 4279) |
SetGoniometer does not immediately sets values |
#5227 (Trac 4380) |
Fix docstring style in mantidplot.py |
#5243 (Trac 4396) |
Hide “Show Box Data Table” from MDworkspace context menu |
#5251 (Trac 4404) |
Add icon to Vates Simple Interface and menu to open that |